http://poj.org/problem?id=3349
http://www.cnblogs.com/yym2013/p/3841378.html
You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.
Input
The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.
Output
If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.
Sample Input
2 1 2 3 4 5 6 4 3 2 1 6 5
Sample Output
Twin snowflakes found.
private static int SNOW_FLAKE_ARMS = 6;
private static int MAP_SIZE = 10000;
public static void main(String[] args) throws NumberFormatException, IOException {
BufferedReader cin = new BufferedReader(new InputStreamReader(System.in));
int n = Integer.parseInt(cin.readLine());
int[][] snowFlake = new int[n][SNOW_FLAKE_ARMS];
Map<Integer, List<Integer>> sumMap = new HashMap<Integer, List<Integer>>(MAP_SIZE);
for (int i = 0; i < n; i++) {
// read data
String[] nums = cin.readLine().split(" ");
for (int j = 0; j < SNOW_FLAKE_ARMS; j++) {
snowFlake[i][j] = Integer.parseInt(nums[j]);
}
// put data
int key = sum(snowFlake, i) % MAP_SIZE;
if (!sumMap.containsKey(key)) {
List<Integer> list = new ArrayList<Integer>();
list.add(i);
sumMap.put(key, list);
} else {
List<Integer> list = sumMap.get(key);
list.add(i);
}
}
// check data
check(sumMap, snowFlake);
}
private static int sum(int[][] arr, int index) {
int sum = 0;
for (int i = 0; i < SNOW_FLAKE_ARMS; i++)
sum += arr[index][i];
return sum;
}
private static void check(Map<Integer, List<Integer>> sumMap, int[][] snowFlake) {
Iterator<Entry<Integer, List<Integer>>> iter = sumMap.entrySet().iterator();
while(iter.hasNext()) {
Entry<Integer, List<Integer>> e = iter.next();
List<Integer> sameSumList = e.getValue();
if (sameSumList != null && sameSumList.size() >= 2) {
for (int i = 0; i < sameSumList.size(); i++) {
for (int j = i + 1; j < sameSumList.size(); j++) {
if (checkOne(snowFlake, sameSumList.get(i), sameSumList.get(j))) {
System.out.println("Twin snowflakes found.");
return;
}
}
}
}
}
System.out.println("No two snowflakes are alike.");
}
private static boolean checkOne(int[][] snowFlake, int i1, int i2) {
for (int i = 0; i < SNOW_FLAKE_ARMS; i++) {
boolean flag = true;
for (int step = 0; step < SNOW_FLAKE_ARMS; step++) {
if (snowFlake[i1][step] != snowFlake[i2][(i + step) % SNOW_FLAKE_ARMS]) {
flag = false;
break;
}
}
if (flag)
return true;
}
for (int i = 0; i < SNOW_FLAKE_ARMS; i++) {
boolean flag = true;
for (int step = 0; step < SNOW_FLAKE_ARMS; step++) {
if (snowFlake[i1][step] != snowFlake[i2][(i + SNOW_FLAKE_ARMS - step) % SNOW_FLAKE_ARMS]) {
flag = false;
break;
}
}
if (flag)
return true;
}
return false;
}